import Foundation
let pattern = #"^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\Deal\v6\.git\logs
C:\Deal\v6\
F:\Deal\v6\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\
C:\
/
/c
\\dwi3342\Deal\v6\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\/)([^\/]*)$
((?:[^\/]*\/)*)(.*)
([\/\\][^\/\\]*$)
^(.*(?:\/|\\))([^\/\\]*)$
^((?:[^\/\\]*\/\\)*)(.*)$
^(?:[a-zA-Z]:[\\\/]|[\\\/])(?:[a-zA-Z0-9_. -]+[\\\/])*(?:[a-zA-Z0-9_. -]+)?$
^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)