#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)medicareId\=(?<medicareId>[^,]+)"
Local $sString = "Message Started processing in Async: MtmCaseActivity(clinicalProgramName=MTM, identificationDate=20210405, caseID=sample, branding=UHC, cycleYear=2021, status=Closed, closingDate=20210419, workedBy=CPP, reworkReason=, fulfillmentId=, identifiers=MtmCaseIdentifierDto(externalMemberId=null, carrierId=MPDOVA, accountId=sample, groupId=sample, memberId=sample, medicareId=sample, contractId=H5253, pbp=050), memberDemographics=MtmMemberDemographicsDto(memberFirstName=PAULINE, memberLastName=TEW, memberDOB=sample, memberAddress1=sample, memberAddress2=, memberCity=sample, memberState=sample, memberZip=sample, patientGender=F), eligibility=MtmEligibilityDto(effectiveDate=sample, termDate=sample), consultationDetails=null)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")