package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)medicareId\=(?<medicareId>[^,]+)`)
var str = `Message Started processing in Async: MtmCaseActivity(clinicalProgramName=MTM, identificationDate=20210405, caseID=sample, branding=UHC, cycleYear=2021, status=Closed, closingDate=20210419, workedBy=CPP, reworkReason=, fulfillmentId=, identifiers=MtmCaseIdentifierDto(externalMemberId=null, carrierId=MPDOVA, accountId=sample, groupId=sample, memberId=sample, medicareId=sample, contractId=H5253, pbp=050), memberDemographics=MtmMemberDemographicsDto(memberFirstName=PAULINE, memberLastName=TEW, memberDOB=sample, memberAddress1=sample, memberAddress2=, memberCity=sample, memberState=sample, memberZip=sample, patientGender=F), eligibility=MtmEligibilityDto(effectiveDate=sample, termDate=sample), consultationDetails=null)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}