$re = '/medicareId\=(?<medicareId>[^,]+)/m';
$str = 'Message Started processing in Async: MtmCaseActivity(clinicalProgramName=MTM, identificationDate=20210405, caseID=sample, branding=UHC, cycleYear=2021, status=Closed, closingDate=20210419, workedBy=CPP, reworkReason=, fulfillmentId=, identifiers=MtmCaseIdentifierDto(externalMemberId=null, carrierId=MPDOVA, accountId=sample, groupId=sample, memberId=sample, medicareId=sample, contractId=H5253, pbp=050), memberDemographics=MtmMemberDemographicsDto(memberFirstName=PAULINE, memberLastName=TEW, memberDOB=sample, memberAddress1=sample, memberAddress2=, memberCity=sample, memberState=sample, memberZip=sample, patientGender=F), eligibility=MtmEligibilityDto(effectiveDate=sample, termDate=sample), consultationDetails=null)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);