// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)medicareId\=(?<medicareId>[^,]+)").unwrap();
let string = "Message Started processing in Async: MtmCaseActivity(clinicalProgramName=MTM, identificationDate=20210405, caseID=sample, branding=UHC, cycleYear=2021, status=Closed, closingDate=20210419, workedBy=CPP, reworkReason=, fulfillmentId=, identifiers=MtmCaseIdentifierDto(externalMemberId=null, carrierId=MPDOVA, accountId=sample, groupId=sample, memberId=sample, medicareId=sample, contractId=H5253, pbp=050), memberDemographics=MtmMemberDemographicsDto(memberFirstName=PAULINE, memberLastName=TEW, memberDOB=sample, memberAddress1=sample, memberAddress2=, memberCity=sample, memberState=sample, memberZip=sample, patientGender=F), eligibility=MtmEligibilityDto(effectiveDate=sample, termDate=sample), consultationDetails=null)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}