# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)_\d+(\.\w+)/$1$2/gm;t' <<< "4711_001.doc"