package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)_\d+(\.\w+)`)
var str = `4711_001.doc`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}