use strict;
my $str = '4711_001.doc';
my $regex = qr/(\d+)_\d+(\.\w+)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";