import re
regex = re.compile(r"(?:^ *uses\r?\n *|\G(?!^))(\w+)(?:,\s*|;$)", flags=re.MULTILINE)
test_str = ("unit ComandesVendes;\n\n"
"interface\n\n"
"uses\n"
" Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms,\n"
" Dialogs, Manteniment;\n\n"
"type\n"
" TFComandesVendes = class(TFManteniment,ActualitzacioFinestra)\n"
" QRCapsaleraNumero: TIntegerField;\n"
" QRCapsaleraData: TDateTimeField;\n"
" QRCapsaleraDataEntrega: TDateTimeField;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")