package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/[A-Za-z0-9_.-]+\/[A-Za-z0-9_.-]+`)
var str = `/google.com/images/video
/msn.com/bing/chat
/bbc.com/video`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}