re = /^\/[A-Za-z0-9_.-]+\/[A-Za-z0-9_.-]+/m
str = '/google.com/images/video
/msn.com/bing/chat
/bbc.com/video'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end