$re = '/^\/[A-Za-z0-9_.-]+\/[A-Za-z0-9_.-]+/m';
$str = '/google.com/images/video
/msn.com/bing/chat
/bbc.com/video';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);