$re = '/Error at line (\d+):|Error at position \(line (\d+)/m';
$str = 'Error at line 34:
Error at position (line 34, column 12):
Duplicate Begin regex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);