re = /Error at line (\d+):|Error at position \(line (\d+)/m
str = 'Error at line 34:
Error at position (line 34, column 12):
Duplicate Begin regex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end