import re
regex = re.compile(r"Error at line (\d+):|Error at position \(line (\d+)", flags=re.MULTILINE)
test_str = ("Error at line 34:\n"
"Error at position (line 34, column 12):\n"
"Duplicate Begin regex")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")