// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Error at line (\d+):|Error at position \(line (\d+)").unwrap();
let string = "Error at line 34:
Error at position (line 34, column 12):
Duplicate Begin regex";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}