using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{3,16}[a-zA-Z0-9\p{L}\p{N}]?(\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{1,48}[a-zA-Z0-9\p{L}\p{N}]){0,4}$";
string input = @"/category name 1/sample sub category/next level sub cat/cat name last";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}