re = /^\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{3,16}[a-zA-Z0-9\p{L}\p{N}]?(\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{1,48}[a-zA-Z0-9\p{L}\p{N}]){0,4}$/m
str = '/category name 1/sample sub category/next level sub cat/cat name last'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end