// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{3,16}[a-zA-Z0-9\p{L}\p{N}]?(\/[a-zA-Z0-9\p{L}\p{N}]{1}[a-zA-Z0-9\p{L}\p{N} &-]{1,48}[a-zA-Z0-9\p{L}\p{N}]){0,4}$").unwrap();
let string = "/category name 1/sample sub category/next level sub cat/cat name last";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}