import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/[a-zA-Z0-9\\p{L}\\p{N}]{1}[a-zA-Z0-9\\p{L}\\p{N} &-]{3,16}[a-zA-Z0-9\\p{L}\\p{N}]?(\\/[a-zA-Z0-9\\p{L}\\p{N}]{1}[a-zA-Z0-9\\p{L}\\p{N} &-]{1,48}[a-zA-Z0-9\\p{L}\\p{N}]){0,4}$";
final String string = "/category name 1/sample sub category/next level sub cat/cat name last";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}