using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*UNIQUE\s+INDEX\s+[`]?[a-z0-9_\$]+[`]?\s*\(\s*([`]?([a-z0-9_\$]+)[`]?\s*[,]?\s*)+\)";
string input = @"UNIQUE INDEX `name` (`name`,`id`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX `test2`( `ewe` , wewe )";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}