$re = '/\s*UNIQUE\s+INDEX\s+[`]?[a-z0-9_\$]+[`]?\s*\(\s*([`]?([a-z0-9_\$]+)[`]?\s*[,]?\s*)+\)/i';
$str = 'UNIQUE INDEX `name` (`name`,`id`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX `test2`( `ewe` , wewe )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);