package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s*UNIQUE\s+INDEX\s+[`]?[a-z0-9_\$]+[`]?\s*\(\s*([`]?([a-z0-9_\$]+)[`]?\s*[,]?\s*)+\)`)
var str = `UNIQUE INDEX \`name\` (\`name\`,\`id\`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX \`test2\`( \`ewe\` , wewe )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}