const regex = /\s*UNIQUE\s+INDEX\s+[`]?[a-z0-9_\$]+[`]?\s*\(\s*([`]?([a-z0-9_\$]+)[`]?\s*[,]?\s*)+\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*UNIQUE\\s+INDEX\\s+[`]?[a-z0-9_\\$]+[`]?\\s*\\(\\s*([`]?([a-z0-9_\\$]+)[`]?\\s*[,]?\\s*)+\\)', 'gi')
const str = `UNIQUE INDEX \`name\` (\`name\`,\`id\`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX \`test2\`( \`ewe\` , wewe )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}