#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\([`\s]*([a-z0-9_\$]+)[`\s]*,[`\s]*([a-z0-9_\$]+)[`\s]*\)"
Local $sString = "UNIQUE INDEX `id` (`id`)" & @CRLF & _
"UNIQUE INDEX `name` (`name`,`id`)" & @CRLF & _
"UNIQUE INDEX test (trt,edw)" & @CRLF & _
"UNIQUE INDEX `test2`( `ewe` , wewe )" & @CRLF & _
"UNIQUE INDEX `test2`( `ewe` , wewe, mary, stewe )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")