package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\([`\s]*([a-z0-9_\$]+)[`\s]*,[`\s]*([a-z0-9_\$]+)[`\s]*\)`)
var str = `UNIQUE INDEX \`id\` (\`id\`)
UNIQUE INDEX \`name\` (\`name\`,\`id\`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX \`test2\`( \`ewe\` , wewe )
UNIQUE INDEX \`test2\`( \`ewe\` , wewe, mary, stewe )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}