import Foundation
let pattern = #"\([`\s]*([a-z0-9_\$]+)[`\s]*,[`\s]*([a-z0-9_\$]+)[`\s]*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
UNIQUE INDEX `id` (`id`)
UNIQUE INDEX `name` (`name`,`id`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX `test2`( `ewe` , wewe )
UNIQUE INDEX `test2`( `ewe` , wewe, mary, stewe )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)