use strict;
my $str = 'UNIQUE INDEX `id` (`id`)
UNIQUE INDEX `name` (`name`,`id`)
UNIQUE INDEX test (trt,edw)
UNIQUE INDEX `test2`( `ewe` , wewe )
UNIQUE INDEX `test2`( `ewe` , wewe, mary, stewe )';
my $regex = qr/\([`\s]*([a-z0-9_\$]+)[`\s]*,[`\s]*([a-z0-9_\$]+)[`\s]*\)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}