re = /mphb_sc_search-wrapper([^"]*)/m
str = '<div class="mphb_sc_search-wrapper extra-class">'
subst = 'mphb_sc_search-wrapper$1 frm_forms with_frm_style'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result