using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9_]*=[A-Za-z][A-Za-z0-9_:|.=\(\)]+|[A-Za-z0-9_]*=\([A-Za-z0-9_:|.=;\(\)\[\]]+\))";
string input = @"sys_rst=(3:2=TRM[7:6];1=RCV1;0=HUGO:SECURE);clk_rst=HIRSCH:mtu.app_rst";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}