re = /([A-Za-z0-9_]*=[A-Za-z][A-Za-z0-9_:|.=\(\)]+|[A-Za-z0-9_]*=\([A-Za-z0-9_:|.=;\(\)\[\]]+\))/
str = 'sys_rst=(3:2=TRM[7:6];1=RCV1;0=HUGO:SECURE);clk_rst=HIRSCH:mtu.app_rst'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end