import Foundation
let pattern = #"([A-Za-z0-9_]*=[A-Za-z][A-Za-z0-9_:|.=\(\)]+|[A-Za-z0-9_]*=\([A-Za-z0-9_:|.=;\(\)\[\]]+\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"sys_rst=(3:2=TRM[7:6];1=RCV1;0=HUGO:SECURE);clk_rst=HIRSCH:mtu.app_rst"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)