$re = '/([A-Za-z0-9_]*=[A-Za-z][A-Za-z0-9_:|.=\(\)]+|[A-Za-z0-9_]*=\([A-Za-z0-9_:|.=;\(\)\[\]]+\))/';
$str = 'sys_rst=(3:2=TRM[7:6];1=RCV1;0=HUGO:SECURE);clk_rst=HIRSCH:mtu.app_rst';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);