#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(00|1|(01|10)((00)*|1*)(0|01*))"
Local $sString = "00" & @CRLF & _
"1" & @CRLF & _
"01000" & @CRLF & _
"1011101" & @CRLF & _
"0111100001110" & @CRLF & _
"0101" & @CRLF & _
"010" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")