const regex = /(00|1|(01|10)((00)*|1*)(0|01*))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(00|1|(01|10)((00)*|1*)(0|01*))', 'mg')
const str = `00
1
01000
1011101
0111100001110
0101
010
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}