import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(00|1|(01|10)((00)*|1*)(0|01*))";
final String string = "00\n"
+ "1\n"
+ "01000\n"
+ "1011101\n"
+ "0111100001110\n"
+ "0101\n"
+ "010\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}