using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(00|1|(01|10)((00)*|1*)(0|01*))";
string input = @"00
1
01000
1011101
0111100001110
0101
010
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}