# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\w+\b)[^\w\r\n]+(?=.*\1)//gm;t' <<< "height(female), weight, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, and BMI.
height(female), weight, BMI, age, and BMI."