const regex = /(\b\w+\b)[^\w\r\n]+(?=.*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w+\\b)[^\\w\\r\\n]+(?=.*\\1)', 'gm')
const str = `height(female), weight, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, and BMI.
height(female), weight, BMI, age, and BMI.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);