re = /(\b\w+\b)[^\w\r\n]+(?=.*\1)/m
str = 'height(female), weight, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, and BMI.
height(female), weight, BMI, age, and BMI.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result