import re
regex = re.compile(r"(\b\w+\b)[^\w\r\n]+(?=.*\1)", flags=re.MULTILINE)
test_str = ("height(female), weight, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, BMI, and BMI.\n\n"
"height(female), weight, BMI, age, and BMI.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)