$re = '/\(([0-9-.]+)\)/m';
$str = 'Alarm Level 1 (D1) [Low (15.7)]
Alarm Level 2 [High (-12.7)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);