re = /\(([0-9-.]+)\)/m
str = 'Alarm Level 1 (D1) [Low (15.7)]
Alarm Level 2 [High (-12.7)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end