import re
regex = re.compile(r"\(([0-9-.]+)\)", flags=re.MULTILINE)
test_str = ("Alarm Level 1 (D1) [Low (15.7)]\n"
"Alarm Level 2 [High (-12.7)]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")