// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([0-9-.]+)\)").unwrap();
let string = "Alarm Level 1 (D1) [Low (15.7)]
Alarm Level 2 [High (-12.7)]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}