import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\/(?:3[0-2]|[12]*\\d)){0,1}[,|-])*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\/(?:3[0-2]|[12]*\\d)){0,1}$";
final String string = "192.168.1.1,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24\n"
+ "192.168.1.1/32\n"
+ "192.168.1.1\n"
+ "192.168.1.1/32\n"
+ "192.168.1.1/12\n"
+ "192.168.1.1/24\n"
+ "192.168.1.1/24\n"
+ "192.168.1.1/0,192.168.1.1/0\n"
+ "10.0.0.0/24\n"
+ "172.16.0.1-172.16.0.255\n"
+ "192.168.1.1,10.0.0.1/24,172.16.0.1-172.16.0.10\n"
+ "64.33.232.212\n"
+ "64.33.232.210/24";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}