import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tag>(?=(?:(?!<\\/?tag>).)*?<b>)(?=(?:(?!<\\/?tag>).)*?\\{1})(?:(?!<\\/?tag>).)*<\\/tag>";
final String string = "<tag><b>{1}test</tag>\n"
+ "<tag><b>test</tag>\n"
+ "<tag><b>{1}test</tag><tag><b>test</tag>\n"
+ "<tag>{1}test</tag><tag><b>test</tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}