import re
regex = re.compile(r"<tag>(?=(?:(?!<\/?tag>).)*?<b>)(?=(?:(?!<\/?tag>).)*?\{1})(?:(?!<\/?tag>).)*<\/tag>", flags=re.MULTILINE)
test_str = ("<tag><b>{1}test</tag>\n"
"<tag><b>test</tag>\n"
"<tag><b>{1}test</tag><tag><b>test</tag>\n"
"<tag>{1}test</tag><tag><b>test</tag>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")