re = /<tag>(?=(?:(?!<\/?tag>).)*?<b>)(?=(?:(?!<\/?tag>).)*?\{1})(?:(?!<\/?tag>).)*<\/tag>/m
str = '<tag><b>{1}test</tag>
<tag><b>test</tag>
<tag><b>{1}test</tag><tag><b>test</tag>
<tag>{1}test</tag><tag><b>test</tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end