import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:(?=(?(3)[\\s\\S]*(?=\\3\\z))(?|.(?=.*\\n(\\1?+.).*\\n(\\2?+.))|.*\\n()())+?(?<=X)(?=.*\\n\\1(?<=X).*\\n\\2(?<=X))(?=([\\s\\S]*\\z)))(?=[\\s\\S]*([\\s\\S](?(4)\\4)))[\\s\\S])+[\\s\\S]*(?=\\4\\z)|\\G(?!\\A|[\\s\\S]?\\z)";
final String string = "....X.......\n"
+ "..X..X...X....\n"
+ "X.X...X..X.....\n"
+ "X....XXXXXX.....\n"
+ "X..XXX...........\n"
+ ".....X..........\n"
+ "..............X\n"
+ "..X...........X....\n"
+ "..X...........X....X...\n"
+ "....X.....";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}